Forums

Help › Forums

WGT Desktop Early Access for Mac

Sat, Nov 25 2023 10:05 AM (290 replies)
  • borntobesting
    9,633 Posts
    Thu, Nov 19 2020 10:18 AM

    dedBuNNy:

    marvin28:

    I am getting an error when I click on the icon in the launcher:

    access to /Applications/Utilities/is forbidden run patcher in administrator mode

     

    You have  couple of options...

    Disable SIP, that often clears this issue up with installers, updating. I find this usually works, Go back and enable it again though, SIP can be a pain but it does serve a purpose on Mac's ...

    Second, run the patcher as root in terminal.

    There may be a simpler option which is right click on the patcher and choose run as administrator. or is that not an option on Macs? 

  • dedBuNNy
    1,919 Posts
    Fri, Nov 20 2020 6:57 AM

    borntobesting:

    There may be a simpler option which is right click on the patcher and choose run as administrator. or is that not an option on Macs? 

    Technically as the main account you are admin as a user, Mac's are basically Unix, well BSD actually, computers if running OSX and not Windows so you have root access and admin and basic users.

    Run as Admin on a Mac would be like running with root access which you would normally do in terminal if required. There is a way to run a Mac as root  but it causes issues for everyday use and is really not recommended.

    There used to be a few ways to work around the problem when needed. Not sure if this works under Big Sur or not. Apple messes with things now and then on OS releases.

    chmod +x ./wgt*.app
    sudo ./wgt*.app

    Then just run that and enter the password.

    These issues with installing and running the game on Mac's is really more something that the developers should have worked out. Apple makes it really clear on how to create applications so they don't cause issues.

  • marvin28
    291 Posts
    Fri, Nov 20 2020 12:03 PM

    Where is the program patcher located? i am a longtime Windows user and have turned to Mac recently and am finding my way on the machine.

     

    Thanks for all of the help,

    Marvin

     

  • dedBuNNy
    1,919 Posts
    Fri, Nov 20 2020 8:43 PM

    The patcher app can't be run on it's own from the terminal, appears it is called from the golf.app and if you try and run it as root you get an 'out of index....' error.

    The patcher gets run when you launch the game.

    Even if you drill down and try and run the EU file, which is an exec unix file, you get the error. It won't even run if the game launcher is open.

    Try disabling SIP. This is really easy. To enable it again, do the same thing only type csrutil enable. and restart.

    1. Turn off your Mac (Apple > Shut Down).
    2. Hold down Command-R and press the Power button. ...
    3. Wait for OS X to boot into the OS X Utilities window.
    4. Choose Utilities > Terminal.
    5. Enter csrutil disable.
    6. Enter reboot.

    If that doesn't do it type this into the terminal 'dsenableroot' you have to create a password. That enables root access. You shouldn't need to do this, but I don't know how you set your machine up so maybe there's some reason.
    Did you create another user on your system? Are you using the account you originally setup the machine with?

    I've installed the  .app on three different Mac's with no issues running at all. You shouldn't be having that admin error. All I do when I first install OSX is disable SIP when installing programs, then enable it after.

    There is one more option you can try to get into the game. Go into contents/application with the 'show package...' drag the golf.app to the Dock. Run that... It bypasses the updater/patcher. Maybe once the game has run, you can run it by using the main WGTGolf.app....

  • Jan31947
    100 Posts
    Mon, Nov 23 2020 6:12 AM

    Champion:  Please send this on to the appropriate technical support department, as I am unable to locate the "improvement to NEW DESKTOP concerns". 

    As an owner, it is imperative that we have the capability to set Tier Limitations for in-house activities and Tournaments. Secondly, the Scorecard does not go back to the front side (9) score at the end of a round, if a picture or (snip) is to be taken of the score, we can't do that any longer.

    Lastly the start/end 24 hour clock seems to be unavailable.  As players debate which activity to play in a limited period of time, they need to know if they have enough time to complete and activity or "tournament" before they start it.  This is also helpful if multiple Directors set new activities for the Club.  When does something expire, so there is room to add another activity.

    Thank you Champion for passing this along to those building the NEW Versions.  Jan31947

  • BigJohn14520
    113 Posts
    Wed, Nov 25 2020 10:16 AM

    is there not a better way to accomplish this?  I would really like to continue playing this game on a mac lap top or mac pc.  Does anyone have  better way rather than messing around with the os?  Thanks for your help.

  • Commish123
    14 Posts
    Wed, Nov 25 2020 10:33 AM

    the only thing I have found is the same game I am playing on my I-pad.  I am not even sure what I am playing is  the OS you refer to  It's fun but not as much as what we play on our desktops.. Damn shame.

  • dedBuNNy
    1,919 Posts
    Wed, Nov 25 2020 3:39 PM

    BigJohn14520:

    is there not a better way to accomplish this?  I would really like to continue playing this game on a mac lap top or mac pc.  Does anyone have  better way rather than messing around with the os?  Thanks for your help.

    To be honest, and everyone knows I'm no WGT shill, there's nothing wrong with the installer. I know that might not sit well as the game won't play, but the game is not accessing anything root, so SIP is actually not an issue (that was a hail mary I put out there to try), but the reality is the only thing you might have to do is grant it access for a couple of functions. I didn't even need to do that much.

    On 4 different Mac's I just downloaded it, dragged it to the Applications folder and ran it, let it download it's update, set up the resolution to suit the screen or monitor and play.

    Issues that you're having are a result of something in your workflow on your system. If you have a configured firewall or are port forwarding for other games in your router.

    Have certain ports blocked for some reason.

    If you're running the drive encryption option in security.

    Any security suite, or AV (though I don't know why)

    If you're trying to run the launcher as a 'non admin' user that you created. That could do it possibly. Again, this game doesn't require root access for anything on your machine. If it did it would not install without all sorts of notifications and requests popping up.

    Maybe not what you were looking for, but its not the file coming from WGT. It's something with the machine you're trying to run it on.

    As an option, try the Steam version if you haven't. It's the same, same install but perhaps it may just get past whatever is causing the downloaded file to not run properly.

     

    *As a test, I deleted the game from this MBP, deleted the library and hidden files as well.

    Downloaded the file again and ran it, and was back into the game, within about 90 seconds. Still have to set things in settings, but I was back into the game no problem.

    It is definitely something on your computer that's preventing it from running the self patcher or app.

     

  • BigJohn14520
    113 Posts
    Wed, Nov 25 2020 6:22 PM

    Thanks for the help.  Regardless of what I try I still get the administrator error.  I'm trying to install on a 2018 Mac book air with Big Sur installed.  the latest version of mac book air OS.  I'm the administrator.  There are no other accounts setup.  What now?...

  • dedBuNNy
    1,919 Posts
    Wed, Nov 25 2020 7:24 PM

    I have that almost exact machine, this one actually, MBP not Air... but pretty well same specs and running Big Sur...

    Its not the Beta is it? It's the new update?

    You're downloading the file linked in this thread correct? https://m.wgt.com/download/apple-desktop?utm_source=wgt&utm_medium=web&utm_campaign=forum_20190925

    Also, can you tell me again at what point you get the admin error?

    There's the installer, that runs, brings up the EUA, you agree and continue and then the patcher runs, downloads the updates, then it runs golf.app and you're in the game at the screen resolution choice, and it goes from there.

     

RSS