Forums

Help › Forums

Ping G430 L81+

Mon, Jul 3 2023 3:46 PM (7 replies)
  • Jacoco1973
    8 Posts
    Thu, Jun 15 2023 6:12 AM

    Quick question, if driver average distance says in Pro Shop 280, what would normally show bottom left on screen when playing? It shows 268 and I'm not getting close to 280 unless strong back wind. Is there something I'm missing?

  • ScottHope
    10,190 Posts
    Thu, Jun 15 2023 8:10 AM

    The Ping G430 that shows in your equipment appears to be a rental that expired over 17 days ago. So perhaps the 268 yards that shows as your driver distance is your previous driver.

    Have a look at this for a possible solution to removing the expired rental.

  • Jacoco1973
    8 Posts
    Thu, Jun 15 2023 8:24 AM

    I bought the Ping special they had now yesterday and equipped. So not sure where the rental showing comes from.

  • Jacoco1973
    8 Posts
    Thu, Jun 15 2023 11:04 AM

    Tried what links says, no difference, still show rental for some reason.

  • ScottHope
    10,190 Posts
    Thu, Jun 15 2023 11:32 AM

    Try sending an email to members@worldgolftour.com to see if they can help you out.

  • Jacoco1973
    8 Posts
    Mon, Jul 3 2023 12:06 PM

    IS WGT ever going to assist? Does this even look right? It shows both equipped. 

     

  • ScottHope
    10,190 Posts
    Mon, Jul 3 2023 3:23 PM

    How to post-a-pic...

  • BlackBogey
    328 Posts
    Mon, Jul 3 2023 3:46 PM

    Do you have a Discord account and link to WGT server on there?  If not, it's very easy and quick to do and I would highly recommend.  Once you do I would be bringing this up on there in the Community Help thread.  Several Mods seem to respond much quicker on there than here, plus there seems to be a bigger audience and maybe someone has gone through exactly what you are.  Another bonus is that you don't have to wait for replies to clear "moderation", so you'll likely get an answer faster.  Another benefit is the ability to upload screenshots instantly without an image hosting service, so you could post a pic of what you are seeing in your equipment page.  You ask "Does this even look right?", but nothing for us to look at to see if it looks right or not.

    When I look at your account/equipment on the website I see Ping Driver, 3wd, Hybrid, Irons, 54W, 60W and Putter.  Are you saying you have 2 Drivers equipped when you go to play a round?  If so, I assume you've tried replacing one with a wedge or whatever club it is you are missing?  Without pictures its difficult to understand exactly what issue you are having.

RSS